WordPress Plugins

All plugins from Wordpress.org directory listed here

GC Message Bar

9237
Version: 2.3.8 - Requires: 3.4 - Compatible up to: 3.9.24 - Last updated: 4 years ago - Downloads: 72,303

GC Message Bar is an easy to use plugin that allows you to place a sticky message and a Call To Action button to the top or bottom of your website

Simple Revisions Delete

10031
Version: 1.4.7 - Requires: 3.5 - Compatible up to: 4.6.14 - Last updated: 2 years ago - Downloads: 35,975

What does it do?

Absolute Privacy

9221
Version: 2.1 - Requires: 3.0 - Compatible up to: 3.6.1 - Last updated: 5 years ago - Downloads: 87,881

New user moderation, site lock-down or members area, users can chose their own password and must enter their name when registering.

WooCommerce Menu Extension

8217
Version: 1.6.2 - Requires: 3.0 - Compatible up to: 5.0.4 - Last updated: 1 month ago - Downloads: 47,351

You can now add woocommerce links in your WP menus.

Manage Notification E-mails

10022
Version: 1.4.2 - Requires: 4.0.0 - Compatible up to: 5.0.4 - Last updated: 2 months ago - Downloads: 47,221

Disable or enable the Wordpress notification e-mails (new user, changed password, etc.). Works perfectly in combination with a lot of other plugins!

Embed Google Map

8410
Version: 3.2 - Requires: 3.0.1 - Compatible up to: 4.0.26 - Last updated: 4 years ago - Downloads: 31,991

Embed Google Map is a plugin for embedding one or more Google Maps to WordPress posts and pages.

Kopa Framework

845
Version: 1.3.5 - Requires: 4.1 - Compatible up to: 4.7.13 - Last updated: 2 years ago - Downloads: 65,506

A WordPress framework by Kopatheme

AutoChimp

6816
Version: 2.15 - Requires: 2.8 - Compatible up to: 3.6.1 - Last updated: 5 years ago - Downloads: 115,186

Keep website users and MailChimp mailing lists in sync and create campaigns from posts.

Advanced Page Manager

8850
Version: 1.6 - Requires: 4.0 - Compatible up to: 4.9.9 - Last updated: 1 year ago - Downloads: 93,173

A new way to create, move, edit and publish your pages for your favorite CMS.

Jigoshop

92225
Version: 1.18.4 - Requires: 4.0 - Compatible up to: 4.8.9 - Last updated: 1 year ago - Downloads: 572,826

A feature-packed eCommerce plugin built upon WordPress core functionality ensuring excellent performance and customizability.

Yelp Widget Pro

7623
Version: 2.0.0 - Requires: 4.2 - Compatible up to: 4.9.10 - Last updated: 8 months ago - Downloads: 50,207

Yelp Widget Pro makes it easy for you to display your Yelp reviews and business information on your website via an easy-to-use and intuitive widget.

Menubar

9415
Version: 5.6.5 - Requires: 4.6 - Compatible up to: 5.1.1 - Last updated: 1 month ago - Downloads: 155,380

Single and multi-level menus for your WordPress site, styled with customizable menu templates.

WP Minify Fix

8040
Version: 1.4.1 - Requires: 2.8 - Compatible up to: 4.3.19 - Last updated: 3 years ago - Downloads: 69,735

[Fixed] This plugin uses the Minify engine to combine and compress JS and CSS files to improve page load time.

Simple Cache

8852
Version: 1.7.1 - Requires: 3.9 - Compatible up to: 5.1.1 - Last updated: 3 months ago - Downloads: 74,808

A very simple plugin to make your site run lightning fast with caching.

Cherry Team Members

604
Version: 1.4.6 - Requires: 4.7 - Compatible up to: 5.1.0 - Last updated: 1 week ago - Downloads: 131,038

Cherry Team Members plugin allows you to showcase your team and personnel. Integrated with Elementor…

WooCommerce – Gift Cards

6041
Version: 2.6.5 - Requires: 3.0 - Compatible up to: 4.9.10 - Last updated: 7 months ago - Downloads: 130,347

Gift Cards for WooCommerce allows you to create gift cards that your customers purchase on…

WooCommerce My Account Widget

7419
Version: 0.6.5 - Requires: 4.8 - Compatible up to: 5.2 - Last updated: 2 weeks ago - Downloads: 78,848

This plugin adds a widget with customer account information to your WooCommerce shop.

Church Content – Sermons, Events and More

9645
Version: 2.2 - Requires: 3.6 - Compatible up to: 5.1.1 - Last updated: 2 months ago - Downloads: 93,192

Provides an interface for managing sermons, events, people and locations. A compatible theme is required for presenting content from these church-cent …

Disable Users

9217
Version: 1.0.5 - Requires: 4.0.0 - Compatible up to: 4.3.19 - Last updated: 3 years ago - Downloads: 25,907

This plugin gives you the ability to disable specific user accounts via a profile setting.

Post Slider by 10Web – Responsive Post Slider

9237
Version: 1.0.58 - Requires: 3.9 - Compatible up to: 5.2 - Last updated: 5 days ago - Downloads: 165,369

Post Slider is a powerful plugin for easily displaying your posts in beautiful sliders.